Debian packages support multiple Python versions now

We have created Debian packages for multiple Python versions. This means that they work now with both Python 2.6 and 2.7 out of the box, or if you compile them manually, with any (supported) version you have installed on your (Debian-based) system.

Practically, this means that now you can install them without manual compiling on current Debian and Ubuntu systems. Give it a try, add our Debian package repository, apt-get install python-orange for Orange library/modules and/or orange-canvas for GUI. If you install the later package, type orange in the terminal and Orange canvas will pop-up.

  • Hans

    Unfortunately this seems not to work for me. I added your repository but when typing apt-get install orange-canvas I get the following message:
    [sudo] password for hans:
    Reading package lists… Done
    Building dependency tree      
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
      orange-canvas: Depends: python-orange (= 0.0.12119~svn-1) but it is not going to be installed
                     Recommends: libpython2.7 (>= 2.7) but it is not installable
    E: Broken packages
    Any idea what I could have done wrong?
    Thanks
    Hans

    • http://mitar.tnode.com Mitar

      Try “apt-get install orange-canvas python-orange”. And on which version/system are you trying to install this?

      • Hans

        I got the same message, except the last sentence:

        The following information may help to resolve the situation:

        The following packages have unmet dependencies:
          python-orange: Depends: python-networkx (>= 1.1) but it is not going to be installed
        E: Broken packages
        I am using an ASUS K70IJ computer with Kubuntu 10.04 as operating system.
        Thanks!

        • http://mitar.tnode.com Mitar

          Is python-networkx package available for your system? Version 1.1 or newer? If not, this is the problem. Sorry, but you need networkX 1.1 version of newer for Orange.

        • http://mitar.tnode.com Mitar

          Try with new package versions. python-networkx is not required anymore (but some features will be missing).